112 lines
3.7 KiB
Diff
112 lines
3.7 KiB
Diff
From 35ab6878d015fef19a76107ecf115348a1049262 Mon Sep 17 00:00:00 2001
|
|
From: root <root@b25ae4c8d32b>
|
|
Date: Fri, 22 May 2020 13:42:49 +0000
|
|
Subject: [PATCH] Fixes for debian build
|
|
|
|
---
|
|
debian/binkd.dirs | 2 +-
|
|
debian/changelog | 4 ++--
|
|
debian/compat | 1 +
|
|
debian/control | 4 ++--
|
|
debian/rules | 22 ++++++++++++----------
|
|
5 files changed, 18 insertions(+), 15 deletions(-)
|
|
create mode 100644 debian/compat
|
|
|
|
diff --git a/debian/binkd.dirs b/debian/binkd.dirs
|
|
index 7785917..0ff11bd 100644
|
|
--- a/debian/binkd.dirs
|
|
+++ b/debian/binkd.dirs
|
|
@@ -1,4 +1,4 @@
|
|
-etc/ftn/
|
|
+etc/binkd/
|
|
usr/sbin/
|
|
var/run/ftn/
|
|
var/spool/ftn/inbound/
|
|
diff --git a/debian/changelog b/debian/changelog
|
|
index 508abeb..40c4495 100644
|
|
--- a/debian/changelog
|
|
+++ b/debian/changelog
|
|
@@ -1,10 +1,10 @@
|
|
-binkd1 (1.0~a.535) unstable; urgency=low
|
|
+binkd (1.1a-109) unstable; urgency=low
|
|
|
|
* Fix man page path
|
|
|
|
-- Stas Degteff <stas_degteff@users.sourceforge.net> Sun, 14 Jun 2009 04:21:47 +0500
|
|
|
|
-binkd1 (1.0~a.531) unstable; urgency=low
|
|
+binkd (1.0~a.531) unstable; urgency=low
|
|
|
|
* Initial Release, debianized by Stas Degteff
|
|
|
|
diff --git a/debian/compat b/debian/compat
|
|
new file mode 100644
|
|
index 0000000..7ed6ff8
|
|
--- /dev/null
|
|
+++ b/debian/compat
|
|
@@ -0,0 +1 @@
|
|
+5
|
|
diff --git a/debian/control b/debian/control
|
|
index 6ebdfb9..1f54202 100644
|
|
--- a/debian/control
|
|
+++ b/debian/control
|
|
@@ -1,4 +1,4 @@
|
|
-Source: binkd1
|
|
+Source: binkd
|
|
Section: comm
|
|
Priority: extra
|
|
Maintainer: Stas Degteff <stas_degteff@users.sourceforge.net>
|
|
@@ -6,7 +6,7 @@ Homepage: http://binkd.grumbler.org
|
|
Build-Depends: debhelper (>> 4.0.0), perl, libperl-dev (>=5.8.8)
|
|
Standards-Version: 3.8.0
|
|
|
|
-Package: binkd1
|
|
+Package: binkd
|
|
Architecture: any
|
|
Depends: ${shlibs:Depends}, perl (>= 5.8.8), adduser
|
|
Description: Binkd - the binkp daemon for FTN communications.
|
|
diff --git a/debian/rules b/debian/rules
|
|
index ef3648e..b9ecddc 100755
|
|
--- a/debian/rules
|
|
+++ b/debian/rules
|
|
@@ -3,16 +3,18 @@
|
|
# Uncomment this to turn on verbose mode.
|
|
export DH_VERBOSE=1
|
|
|
|
-export DH_COMPAT=4
|
|
+SHELL := bash
|
|
+
|
|
+#export DH_COMPAT=4
|
|
#export DEBIAN=1
|
|
-PACKAGE=binkd1
|
|
-MAJOR=`sed -n "/\#define MAJOR/s/.*\([0-9]\+\).*$$/\1/p" Config.h`
|
|
-MINOR=`sed -n "/\#define MINOR/s/.*\([0-9]\+\).*$$/\1/p" Config.h`
|
|
-SUFFIX=`sed -n "/\#define SUFFIX/s/.*\"\([-a-z]\+\)\".*$$/\1/p" Config.h`
|
|
-PATCHLEVEL=`sed -n "/\#define PATCHLEVEL/s/.*\([0-9]\+\).*$$/\1/p" Config.h`
|
|
-VERSION=$(MAJOR).$(MINOR)+$(SUFFIX)$(PATCHLEVEL)
|
|
-PREFIX=$(CURDIR)/debian/binkd1
|
|
-CONFIGURE_OPTIONS += --with-zlib --with-https --with-ntlm --with-bwlim --with-perl --sysconfdir=$(PREFIX)/etc/ftn --prefix=$(PREFIX) --mandir=$(PREFIX)/usr/share/man
|
|
+PACKAGE=binkd
|
|
+MAJOR=`sed -n "/\#define MAJOR/s/.*\ \([0-9]\+\).*$$/\1/p" Config.h`
|
|
+MINOR=`sed -n "/\#define MINOR/s/.*\ \([0-9]\+\).*$$/\1/p" Config.h`
|
|
+SUFFIX=`sed -n "/\#define SUFFIX/s/.*\ \"\([-a-z]\+\)\".*$$/\1/p" Config.h`
|
|
+PATCHLEVEL=`sed -n "/\#define PATCHLEVEL/s/.*\ \([0-9]\+\).*$$/\1/p" Config.h`
|
|
+VERSION=$(MAJOR).$(MINOR)$(SUFFIX)-$(PATCHLEVEL)
|
|
+PREFIX=$(CURDIR)/debian/binkd
|
|
+CONFIGURE_OPTIONS += --with-zlib --with-https --with-ntlm --with-bwlim --with-perl --sysconfdir=$(PREFIX)/etc/binkd --prefix=$(PREFIX) --mandir=$(PREFIX)/usr/share/man
|
|
|
|
# These are used for cross-compiling and for saving the configure script
|
|
# from having to guess our platform (since we know it already)
|
|
@@ -68,7 +70,7 @@ install: build
|
|
|
|
$(MAKE) install
|
|
install -d $(PREFIX)/usr/share/doc/$(PACKAGE)
|
|
- install \!README* HISTORY *.[Tt][Xx][Tt]* doc/*.{txt,html,htm} $(PREFIX)/usr/share/doc/$(PACKAGE)/
|
|
+ install \README* HISTORY *.[Tt][Xx][Tt]* doc/*.{txt,html,htm} $(PREFIX)/usr/share/doc/$(PACKAGE)/
|
|
|
|
# Build architecture-independent files here.
|
|
binary-indep: build install
|
|
--
|
|
2.20.1
|
|
|